Difference between revisions of "Yum Repository"

From pgpool Wiki
Jump to: navigation, search
 
(9 intermediate revisions by 3 users not shown)
Line 4: Line 4:
  
 
With this repository, you can install pgpool-II and pgpoolAdmin etc. by using yum.
 
With this repository, you can install pgpool-II and pgpoolAdmin etc. by using yum.
 +
Please visit:
 +
http://www.pgpool.net/docs/latest/en/html/install-rpm.html
 +
for more details of RPM installation.
  
The pgpool-II yum repository currently supports pgpool-II 3.3 or above with RHEL6/RHEL7 x86_64.
+
The pgpool-II yum repository currently supports pgpool-II 3.4 or above with RHEL6/RHEL7 x86_64 (and RHEL compatible distributions like CentOS).
  
 
To use the yum repository, you must first install the repository RPM. To do this, download the correct RPM from the repository RPM listing, and install it with commands like:
 
To use the yum repository, you must first install the repository RPM. To do this, download the correct RPM from the repository RPM listing, and install it with commands like:
 +
 +
* RHEL/CentOS 7.x (Pgpool-II 4.1)
 +
# yum install http://www.pgpool.net/yum/rpms/4.1/redhat/rhel-7-x86_64/pgpool-II-release-4.1-1.noarch.rpm
 +
 +
* RHEL/CentOS 7.x (Pgpool-II 4.0)
 +
# yum install http://www.pgpool.net/yum/rpms/4.0/redhat/rhel-7-x86_64/pgpool-II-release-4.0-1.noarch.rpm
 +
 +
* RHEL/CentOS 7.x (Pgpool-II 3.7)
 +
# yum install http://www.pgpool.net/yum/rpms/3.7/redhat/rhel-7-x86_64/pgpool-II-release-3.7-1.noarch.rpm
 +
 +
* RHEL/CentOS 7.x (Pgpool-II 3.6)
 +
# yum install http://www.pgpool.net/yum/rpms/3.6/redhat/rhel-7-x86_64/pgpool-II-release-3.6-1.noarch.rpm
  
 
* RHEL/CentOS 7.x (Pgpool-II 3.5)
 
* RHEL/CentOS 7.x (Pgpool-II 3.5)
Line 14: Line 29:
 
* RHEL/CentOS 7.x (Pgpool-II 3.4)
 
* RHEL/CentOS 7.x (Pgpool-II 3.4)
 
  # yum install http://www.pgpool.net/yum/rpms/3.4/redhat/rhel-7-x86_64/pgpool-II-release-3.4-1.noarch.rpm
 
  # yum install http://www.pgpool.net/yum/rpms/3.4/redhat/rhel-7-x86_64/pgpool-II-release-3.4-1.noarch.rpm
 +
 +
* RHEL/CentOS 6.x (Pgpool-II 4.1)
 +
# yum install http://www.pgpool.net/yum/rpms/4.1/redhat/rhel-6-x86_64/pgpool-II-release-4.1-1.noarch.rpm
 +
 +
* RHEL/CentOS 6.x (Pgpool-II 4.0)
 +
# yum install http://www.pgpool.net/yum/rpms/4.0/redhat/rhel-6-x86_64/pgpool-II-release-4.0-1.noarch.rpm
 +
 +
* RHEL/CentOS 6.x (Pgpool-II 3.7)
 +
# yum install http://www.pgpool.net/yum/rpms/3.7/redhat/rhel-6-x86_64/pgpool-II-release-3.7-1.noarch.rpm
 +
 +
* RHEL/CentOS 6.x (Pgpool-II 3.6)
 +
# yum install http://www.pgpool.net/yum/rpms/3.6/redhat/rhel-6-x86_64/pgpool-II-release-3.6-1.noarch.rpm
  
 
* RHEL/CentOS 6.x (Pgpool-II 3.5)
 
* RHEL/CentOS 6.x (Pgpool-II 3.5)

Latest revision as of 04:28, 6 September 2019

PgPool Global Development Group provides the pgpool-II Yum Repository.

http://www.pgpool.net/yum/

With this repository, you can install pgpool-II and pgpoolAdmin etc. by using yum. Please visit: http://www.pgpool.net/docs/latest/en/html/install-rpm.html for more details of RPM installation.

The pgpool-II yum repository currently supports pgpool-II 3.4 or above with RHEL6/RHEL7 x86_64 (and RHEL compatible distributions like CentOS).

To use the yum repository, you must first install the repository RPM. To do this, download the correct RPM from the repository RPM listing, and install it with commands like:

  • RHEL/CentOS 7.x (Pgpool-II 4.1)
# yum install http://www.pgpool.net/yum/rpms/4.1/redhat/rhel-7-x86_64/pgpool-II-release-4.1-1.noarch.rpm
  • RHEL/CentOS 7.x (Pgpool-II 4.0)
# yum install http://www.pgpool.net/yum/rpms/4.0/redhat/rhel-7-x86_64/pgpool-II-release-4.0-1.noarch.rpm
  • RHEL/CentOS 7.x (Pgpool-II 3.7)
# yum install http://www.pgpool.net/yum/rpms/3.7/redhat/rhel-7-x86_64/pgpool-II-release-3.7-1.noarch.rpm
  • RHEL/CentOS 7.x (Pgpool-II 3.6)
# yum install http://www.pgpool.net/yum/rpms/3.6/redhat/rhel-7-x86_64/pgpool-II-release-3.6-1.noarch.rpm
  • RHEL/CentOS 7.x (Pgpool-II 3.5)
# yum install http://www.pgpool.net/yum/rpms/3.5/redhat/rhel-7-x86_64/pgpool-II-release-3.5-1.noarch.rpm
  • RHEL/CentOS 7.x (Pgpool-II 3.4)
# yum install http://www.pgpool.net/yum/rpms/3.4/redhat/rhel-7-x86_64/pgpool-II-release-3.4-1.noarch.rpm
  • RHEL/CentOS 6.x (Pgpool-II 4.1)
# yum install http://www.pgpool.net/yum/rpms/4.1/redhat/rhel-6-x86_64/pgpool-II-release-4.1-1.noarch.rpm
  • RHEL/CentOS 6.x (Pgpool-II 4.0)
# yum install http://www.pgpool.net/yum/rpms/4.0/redhat/rhel-6-x86_64/pgpool-II-release-4.0-1.noarch.rpm
  • RHEL/CentOS 6.x (Pgpool-II 3.7)
# yum install http://www.pgpool.net/yum/rpms/3.7/redhat/rhel-6-x86_64/pgpool-II-release-3.7-1.noarch.rpm
  • RHEL/CentOS 6.x (Pgpool-II 3.6)
# yum install http://www.pgpool.net/yum/rpms/3.6/redhat/rhel-6-x86_64/pgpool-II-release-3.6-1.noarch.rpm
  • RHEL/CentOS 6.x (Pgpool-II 3.5)
# yum install http://www.pgpool.net/yum/rpms/3.5/redhat/rhel-6-x86_64/pgpool-II-release-3.5-1.noarch.rpm
  • RHEL/CentOS 6.x (Pgpool-II 3.4)
# yum install http://www.pgpool.net/yum/rpms/3.4/redhat/rhel-6-x86_64/pgpool-II-release-3.4-1.noarch.rpm

Once this is done, you can proceed to install and update the packages from the offcial repository by using yum.

Package names in the pgpool-II yum repository includes the version number of PostgreSQL to use with pgpool-II, such as:

pgpool-II-pg95
pgpool-II-pg95-extensions